Treasure map not working

Since the last update I've found in barrels, or obtained from "Man Overboard!" dozen of maps, but everytime I click on it nothing happenes. Please solve this problem, I'm not using the mobile version.
is it working yet? Just checking
I have been having the same problem. Beat up a madman to get the treasure map and then nothing.
Still not working, please fix it
Just tried another treasure map but nothing happened
the old Verizon commercial popped into my head..."Can You Hear Me Now?" I wonder why
It's still a problem, please fix it.
You found Treasure Map (1 pcs) on the sinra. I used it but nothing happened
Compass isn't working too
Still not working
Lady Raya., Lady Raya.,

Impy, not at all by I want to keep trying
This is still not working. Click on the map and it just disappears......Does anybody know if I am still doing anything wrong?
Raister, it's not you. it's still broken for everyone. compass and map appear to do nothing.
You need to log in or register before leaving a comment.